The Forums Are Now Closed!

The content will remain as a historical reference, thank you.

[FIX:] Graphics Gone Wild.

for ATI users with bonkers graphics.

By on March 26, 2009 4:22:55 AM from Demigod Forums Demigod ForumsExternal Link

you'll find this thread useful if;

  1. you have an ATI card of some flavour,
  2. your Demigod looks like this;
this just happens to be caused by, a clever little performance improving, technology called Geometric Instancing being disabled on your card. it appears that the Moho Engine (used in both SupCom and Demigod) makes use of this, and it vainly tries to continue even when it's been disabled. 
as you can see; the results are amuzing, but not at all useful for play.
fortunately, it's rectified with no further ill effects by re-enabling Geometric Instancing at any point in time.
now, if you're a sufferer of a lack of Instancing, here's a simple tutorial on fixing it;
  1. download ATI Tray Tools, as per my external link (don't worry, you can uninstall it later),
  2. install it (well, duh),
  3. you'll likely be asked to turn off some services (namely; ATI HotKey Service) in order to do something about low-level overclocking
    • don't disable them unless you plan on making further use of ATITool,
    • disabling them doesn't contribute anything to fixing your graphics.
  4. once ATITool is up and running, point to Tweaks -> Standard Tweaks,
  5. tick Geometry Instancing,
  6. ???
  7. profit.

Tweaks -> Standard Tweakstick Geometry Instancing.
[EDIT:] something that wasn't mentioned; this applies to the DG beta, AND to the finished product. it's not a bug per-say with the game, as such; don't expect to see a fix made by GPG.


+37 Karma | 4 Replies
March 26, 2009 3:13:36 PM from Stardock Forums Stardock Forums

How very cool! thanks BM!


March 27, 2009 6:38:23 PM from Demigod Forums Demigod Forums


Here's the screenshot:


Graphics Gone Wild



Just as an FYI, for Vista x64 users they will not be able to install the ATI Tray Tools software due to an unsigned driver.  This is corrected in the latest beta version, which can be found here:

Again, there is a 1.3 release version and a 1.6 beta - If you're on Vista x64 you need the 1.6 beta.



Okay, got the tools installed and went to the tweaks as you specified.  Unfortunately, geometry instancing was already checked, so I may have another issue...


EDIT #2 <--- Important!

Playing around with the tool, I disabled OPTIMIZE PIXEL SHADER CODE and now it's working like a charm.



Okay this gets stranger and stranger.  disabling the option above fixed the graphics problem, but man oh man did things run like crap.  However, I turned it back on and... guess what... everything still works (?!?!).

You know I love ATI and all, but their reputation for horrid drivers is well deserved... yeesh.


March 27, 2009 11:10:21 PM from Stardock Forums Stardock Forums

This hasnt worked for me....

i still get those graphical glitches

March 27, 2009 11:24:06 PM from Stardock Forums Stardock Forums

I fixed it!!

i reinstalled my drivers for my card (again) after installing the atitray tool thing, and disabled the pixel shader and it still runs beautifully!!!

Thanks for the help guys!!

Stardock Forums v1.0.0.0    #108435  walnut2   Server Load Time: 00:00:00.0000187   Page Render Time:

Stardock Magazine | Register | Online Privacy Policy | Terms of Use

Copyright ?? 2012 Stardock Entertainment and Gas Powered Games. Demigod is a trademark of Gas Powered Games. All rights reserved. All other trademarks and copyrights are the properties of their respective owners. Windows, the Windows Vista Start button and Xbox 360 are trademarks of the Microsoft group of companies, and 'Games for Windows' and the Windows Vista Start button logo are used under license from Microsoft. ?? 2012 Advanced Micro Devices, Inc. All rights reserved. AMD, the AMD Arrow logo and combinations thereof are trademarks of Advanced Micro Devices, Inc.